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This chapter shows the basics of AC simulations, including small
signal gain and noise. It also shows many detailed features of the
system.

Lab 3: AC Simulations
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OBJECTIVES

• Perform AC small-signal and noise simulations

• Sweep variables, tune parameters, write equations

• Control plots, traces, datasets, and AC sources

About this lab: This lab continues the mixer project and uses the same sub-circuit as
the previous lab.

PROCEDURE

1. Use copy/paste to create a design

a. Open the last design from lab 2 (dc_net) and select (Shift click) the
following items: Vdc, both bias resistors, the bjt_pkg, and the ground.
Then click: Edit > Copy / Paste > Copy to buffer.  Select the Default
origin and then close the window.

b. Use the File> New command to create a new schematic window and
name it: ac_sim.   Then click Edit > Copy/Paste > Paste from buffer
and insert the ghost image on the schematic.

c. Save the new file.  You must save it or it will not be written to the disk
drive.
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d. Continue building the circuit shown here using the following steps:

e. Insert the remaining components: AC Simulation controller, dc
blocking capacitors, and the V_AC voltage source, 50 ohm load,
etc. Use the palettes to find the desired items.

f. Add Vcc as a Node Name instead of using a wire.

g. Add Vin and Vout as Node Names also.

h. Select the bjt_pkg and push into the sub-circuit
(using the icon) to verify that it is your circuit, and
then push out again.

2. Set up the AC Simulation

a. Insert an AC Simulation
controller.

NOTE: After inserting a
node name, use the F5
key to move component
text as needed.
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b. Edit the AC controller start, stop, and
step as shown here.

c. Turn on the Calculate noise button
and add the Vout node.  Also, set the
Mode to Sort by Name.  You could
sort by value to see the greatest
contibutors listed first and then list the
name in order to locate them on the
schematic (good for large circuits)

d. Turn on the Display for each of the
parameters.

e. Simulate the circuit: press the F7 key (default dataset name is the same
as the schematic: ac_sim).  Look at the status window.  It should give a
warning message like the one here because the default simulation-
temperature is room temperature (25o C) and not at the IEEE standard
for noise measurements (290o Kelvin).

3. Set the Options card and Simulate

From the simulation palette, insert the Options
card.  This is a global used for temperature.  Set
Temp to 16.85. Simulate again and there
should be no warning message.  The Options
card also sets the tolerance for DC solutions.
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4. Display the noise data

a. Open a new data display and save it as ac_data.

b. Insert a list of name and vnc (voltage noise contributors) and click Plot
Options and Suppress Table Format.  As shown here, Q1.BJT1 is the
total noise voltage for the device. It is composed of two pieces:
Q1.BJT1.ibe and Q1.BJT1.ice. This means that the total BJT noise comes
from both the base-emitter current (ibe) and collector-emitter current
(ice).
However, these are two uncorrelated noise voltages that have been
added as noise powers:      (Vtotal)2 = (Vibe)2 + (Vice)2.
Also, note that the total vnc is the same as Vout noise. If you have time,
insert a separate list of Vout.noise and verify this.

c. Save the data display.

5. Write a Measurement Equation to calculate gain

a. Insert a MeasEqn from the AC simulation palette.  Or, you can type in
MeasEqn in the component history list.

b. Now, edit the equation so it looks like the one shown.  It computes the
gain in dB using voltages at name nodes Vin and Vout:
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6. Simulate without noise and display the results

a. In the schematic, turn off the noise
calculation by editing the simulation controller
setting on-screen. Turning off the noise
calculation will save simulation time and data,
especially for large circuits. Of course, this will
make the list you inserted (name and vnc)
become invalid.

b. Save the schematic. Simulate again.  When the simulation is finished,
insert the Gain_db equation in a list.

c. Now, in the data display, insert an equation to calculate the same
gain.  However, this time give it a different name, such as dB_Gain:

d. Edit the list and add the data display equation: dB_Gain.  Now you
have two results (they are the same) from two equations – one written
before simulation and one after simulation.

Equation from schematic Equation from data display
dispdisplaydisplay
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e. Edit the list one more time and add Vout.  With the
Vout data selected, click the Trace Options button.

f. In the Trace Expression field, change Vout to read: dB
(Vout) as shown and click OK.  You are using the built-in
dB function on the Vout data. Because the AC signal at
Vin is 1 volt, the dB value of Vout will have the same
value as the dB gain equations you wrote.

NOTE on equations: The point of these last steps was to show the similarity and
difference between equations you write in schematic and those you write in the data
display.  In addition, you should remember that variable equations in schematic
(VarEqn) are primarily used to initialize (declare) variables sweeping, scaling, etc.

7. Use the what function on the Vout data

a. Insert a new list (dataset is still ac_sim).   Add the Vout data again,
select it, and click on the Trace Options button.

b. When the dialog box appears, insert the cursor in front of the trace
expression and type the what function in front of the dB of Vout as
shown here, using parentheses on each side.  Click OK and you get the
similar information as clicking Variable Info but you get it for the
explicit expression: dB(Vout).  Of course, the dependency is the same
for dB(Vout) and Vout: freq. Try clicking Variable Info and see. Later
on, you will use this function to determine how to index into dataset
values, especially S-parameters and harmonic balance simulations where
there is mixing.
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8. Copy the data display equation using Ctrl C Ctrl V

a. Select the dB_Gain equation and then press: Ctrl C and Ctrl V.  Move
the cursor and click nearby.  The highlighted copy of the equation will
appear with “1’ appended to the equation name (dB_Gain1).

b. Edit the copied equation to become a voltage gain equation:

c. Return to the schematic, change the simulation stop frequency to 10
GHz, and simulate.

d. In the data display, insert a plot and add the v_Gain equation.  You
should see a plot similar to the one here showing the voltage gain.
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9. Tune the beta parameter:

a. Position the schematic window and the data display so you can see them
both. The select the bjt_pkg and start the tune mode (Simulate
>Tuning).  Put a marker on the trace – as you tune the parameter, the
marker will move to the most recent trace.

b. Try clicking Update to see the updated value of beta on the schematic.
Note that the Reset button only resets the initial value on the Tune
Control dialog.  Be sure that beta is 144 when you Cancel the tuning or
simply edit beta on the schematic to be 144.
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10.  Use another source for the analysis

This step shows how sources are related to simulation controllers.  By
substituting a different source in the design, you will see the relationship.
The V_AC, I_AC and P_AC sources are specifically designed for use with
the AC Simulation controller.  However, almost any frequency domain
source can be used for an AC simulation if it has the Vac, Iac or Pac
variable.

a. In the circuit schematic, select the V_AC source and move it (Edit >
Move > Move and Disconnect) to the side of the schematic and
deactivate it.

b. Insert a V_1Tone source (Frequency Domain
sources).  This source is designed to be used
with the harmonic balance simulator but can
be used here also. Note the difference in the
default for freq (= freq or 1 Ghz).

c.  Simulate with the dataset name = V_1.

d. In the data display, insert a plot of the
magnitude of Vout.

e. Go back and change the voltage from 1
V to 100 volts: V=polar (100,0) V. Now,
set the dataset name as: V_100.
Simulate and add the trace to the plot.
You will see the exact same value. The
next step will explain this…

Activate and Deactivate icons



Lab 3: AC Simulations

3-11

f. The AC simulation controller only reads the Vac setting.  Because the
source can be used with different simulation controllers, the setting of V
is necessary. Therefore, edit the source so that the Vac=5 volts and that
the Vac setting is displayed.

g. Simulate again with the same dataset name: V_5.  When the simulation
is finished, edit the plot and add the magnitude of V_5 to the plot and
you should now see the two traces.

h. Delta Marker Mode: Insert a marker on each trace at 1 GHz.  Then
select the two markers (shift click) and then click: Marker > Delta
Mode On and choose M2 as the reference.   The text will show the
difference between the two markers on the Y axis.  Move m1 to 2 GHz
and see the change in the displayed marker text.

V is not used by the
AC simulator.  But
Vac is used.
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11.  Sweep Vcc (as if the battery voltage dropped below 2 volts)

This step will require you to use the skills you already learned in this lab and
in lab 2.  You will set up a parameter sweep for Vdc from 1.8 to 2 volts in
0.05 volt steps.

a. Replace the V_1Tone source with a V_AC source and deactivate the
V_1Tone – use the command Edit > Move > Move and Disconnect
and Edit > Component > Deactivate.

b. Insert a VAR (variable equation)
initializing Vbias = 2 volts.

c.  Redefine Vcc: Vdc = Vbias.

d. Insert a Parameter Sweep.  Then set the SweepVar
(sweep variable) to be Vbias, and be sure the
Simulation Instance Name of the AC simulation
controller is also set.

e. Simulate as ac_bat_swp (dataset name) and then
display the magnitude of the Vout data as shown.

12.  Save all your work and
close the windows

Simulated battery drain over
broad frequency range. Also,
Trace Options used to thicken
the trace lines.
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EXTRA EXERCISES:

1. Simulate with port noise and ports.  To do this, use a P_AC source as the input
port (Num=1) and place a Term on the output as port 2 (Num=2). These two
components are shown here with the port numbers.

2. Insert the I_AC constant current source and simulate.  To do this, you need to put
a large resistance in parallel with the source because the simulator needs to verify
a dc path to ground and the current sources are open circuits.

3. Insert the P_AC source and look at the power gain.  Also, sweep another
parameter and plot the results.

4. Try using the node settings in the AC simulation palette.  You can set initial
voltages at nodes using the Node Set or by referring to name nodes using the
NodeSetByName component.
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专注于微波、射频、天线设计人才的培养 易迪拓培训 
网址：http://www.edatop.com  

 

射 频 和 天 线 设 计 培 训 课 程 推 荐 

 

易迪拓培训(www.edatop.com)由数名来自于研发第一线的资深工程师发起成立，致力并专注于微

波、射频、天线设计研发人才的培养；我们于 2006 年整合合并微波 EDA 网(www.mweda.com)，现

已发展成为国内最大的微波射频和天线设计人才培养基地，成功推出多套微波射频以及天线设计经典

培训课程和 ADS、HFSS 等专业软件使用培训课程，广受客户好评；并先后与人民邮电出版社、电子

工业出版社合作出版了多本专业图书，帮助数万名工程师提升了专业技术能力。客户遍布中兴通讯、

研通高频、埃威航电、国人通信等多家国内知名公司，以及台湾工业技术研究院、永业科技、全一电

子等多家台湾地区企业。 

易迪拓培训课程列表：http://www.edatop.com/peixun/rfe/129.html 

 

 

射频工程师养成培训课程套装 

该套装精选了射频专业基础培训课程、射频仿真设计培训课程和射频电

路测量培训课程三个类别共 30 门视频培训课程和 3 本图书教材；旨在

引领学员全面学习一个射频工程师需要熟悉、理解和掌握的专业知识和

研发设计能力。通过套装的学习，能够让学员完全达到和胜任一个合格

的射频工程师的要求… 

课程网址：http://www.edatop.com/peixun/rfe/110.html 

ADS 学习培训课程套装 

该套装是迄今国内最全面、最权威的 ADS 培训教程，共包含 10 门 ADS

学习培训课程。课程是由具有多年 ADS 使用经验的微波射频与通信系

统设计领域资深专家讲解，并多结合设计实例，由浅入深、详细而又

全面地讲解了 ADS 在微波射频电路设计、通信系统设计和电磁仿真设

计方面的内容。能让您在最短的时间内学会使用 ADS，迅速提升个人技

术能力，把 ADS 真正应用到实际研发工作中去，成为 ADS 设计专家...

课程网址： http://www.edatop.com/peixun/ads/13.html  

 

HFSS 学习培训课程套装 

该套课程套装包含了本站全部 HFSS 培训课程，是迄今国内最全面、最

专业的HFSS培训教程套装，可以帮助您从零开始，全面深入学习HFSS

的各项功能和在多个方面的工程应用。购买套装，更可超值赠送 3 个月

免费学习答疑，随时解答您学习过程中遇到的棘手问题，让您的 HFSS

学习更加轻松顺畅… 

课程网址：http://www.edatop.com/peixun/hfss/11.html 
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CST 学习培训课程套装 

该培训套装由易迪拓培训联合微波 EDA 网共同推出，是最全面、系统、

专业的 CST 微波工作室培训课程套装，所有课程都由经验丰富的专家授

课，视频教学，可以帮助您从零开始，全面系统地学习 CST 微波工作的

各项功能及其在微波射频、天线设计等领域的设计应用。且购买该套装，

还可超值赠送 3 个月免费学习答疑… 

课程网址：http://www.edatop.com/peixun/cst/24.html  

 

HFSS 天线设计培训课程套装 

套装包含 6 门视频课程和 1 本图书，课程从基础讲起，内容由浅入深，

理论介绍和实际操作讲解相结合，全面系统的讲解了 HFSS 天线设计的

全过程。是国内最全面、最专业的 HFSS 天线设计课程，可以帮助您快

速学习掌握如何使用 HFSS 设计天线，让天线设计不再难… 

课程网址：http://www.edatop.com/peixun/hfss/122.html 

13.56MHz NFC/RFID 线圈天线设计培训课程套装 

套装包含 4 门视频培训课程，培训将 13.56MHz 线圈天线设计原理和仿

真设计实践相结合，全面系统地讲解了 13.56MHz线圈天线的工作原理、

设计方法、设计考量以及使用 HFSS 和 CST 仿真分析线圈天线的具体

操作，同时还介绍了 13.56MHz 线圈天线匹配电路的设计和调试。通过

该套课程的学习，可以帮助您快速学习掌握 13.56MHz 线圈天线及其匹

配电路的原理、设计和调试… 

详情浏览：http://www.edatop.com/peixun/antenna/116.html 
 

我们的课程优势： 

※ 成立于 2004 年，10 多年丰富的行业经验， 

※ 一直致力并专注于微波射频和天线设计工程师的培养，更了解该行业对人才的要求 

※ 经验丰富的一线资深工程师讲授，结合实际工程案例，直观、实用、易学 

联系我们： 

※ 易迪拓培训官网：http://www.edatop.com 

※ 微波 EDA 网：http://www.mweda.com 

※ 官方淘宝店：http://shop36920890.taobao.com 
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